92-On-New Power failure
Incident Report for Network Status Page
Resolved
This incident has been resolved.
Posted Oct 11, 2024 - 15:27 SAST
Monitoring
Power has restored
Posted Oct 10, 2024 - 19:30 SAST
Investigating
Good Day,

Please Note City power is experiencing an outage at the moment and 92-On-New is currently affected.

Thank you
Posted Oct 10, 2024 - 15:02 SAST
This incident affected: 92-on-New.