Power failure @92-On-New and The Heights Estate
Incident Report for Network Status Page
Resolved
Good Morning,

Please note power has restored.

Thank you
Posted Dec 05, 2024 - 08:09 SAST
Update
92N has restored, however the Heights is still down
Posted Dec 04, 2024 - 13:02 SAST
Investigating
Good day,

Please note some of our Midrand estates (The Heights and 92-On-New ) are currently experiencing power failure.

Thank you
Posted Dec 04, 2024 - 09:40 SAST
This incident affected: 92-on-New and The Heights.